Mac OS X升级PHP版本

Posted: 2015-11-14  By  vilay  |  Views(4536)

Mac 10.10下自带的PHP版本是5.5的,因为Laravel 5.1最低版本要PHP >= 5.5.9,所以升级php5.6,记录下升级php过程 apache mysql php环境搭建可参考

通过Brew安装

安装Brew

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

安装完成之后,最后使用命令检测下

brew doctor

如有提示安装xcode-select使用下面命令安装

xcode-select --install

命令列表

brew update  #更新源

brew search php56 #查找php5.6

brew install php56  #安装php5.6

brew options php56 #查看编译参数

brew tap xxxx  #添加源

开始安装,添加源

brew tap homebrew/php  或者  brew tap josegonzalez/homebrew-php

brew tap homebrew/dupes

如果需要删除安装包

brew untap xxxxx

安装php5.6

brew install php56

安装完成之后,安装路径是/usr/local/Cellar/php56

默认使用php5.6需要修改环境变量

sudo vi ~/.bashrc

添加如下语句

export PATH="/usr/local/bin:/usr/local/sbin:$PATH"

修改Apache配置文件

sudo vi /etc/apache2/httpd.conf

修改配置

LoadModule php5_module  libexec/apache2/libphp5.so 

修改为

LoadModule php5_module  /usr/local/Cellar/php56/5.6.15/libexec/libphp5.so 

重启Apache即可

sudo apachectl restart